[Nuke] error creating DeepRead node

Why do I get error saying ‘NoneType Object has no attribute rfind’ when i create a DeepRead node with

deepRead =  nuke.createNode("DeepRead") 

this error message is on the label of the node and in terminal… neither in script editor…

What happens when you do:


Also which Nuke version are you on? There are a few bugs in their python code from version to version.

same error , already tried it

What Nuke Version are you on? Works in 7.0v4 for me, fails in 6.3v8.

And for the record, the issue seems to be Autolable rather than the node. Here’s a workaround:

nuke.createNode( “DeepRead”, “file {’//server/test/test.exr’}”, inpanel = True)

I think the issue is that Autolable breaks if the DeepRead does not have a file set.


precisely though it shouldnt be…

Absolutely. As said it is fixed for newer versions though.

did Foundry every mentioned this bug on there website ? from which version onwards it got fixed probably their might be more fixes than this…

It was fixed between 6.3v9 and 7.0v1. The release notes are here: http://thefoundry.s3.amazonaws.com/products/nuke/releases/7.0v1/7.0v1_ReleaseNotes.pdf
Got no idea if it is in there. Not everything finds its way into the release notes. Or it might be fixed indirectly by another issue.