Convert to NURBS crashes Maya

Hi Devs,

I have a wired case, converting polygon geometry to NURBS with a script crashes Maya on a particular object. Printing each step and it looks like a crash is happening on the NURBS step after Poly to Subdiv conversion done.

If I run the conversion piece of code only from Script Editor there are even no errors happening:

string $subdiv_geo[] = `polyToSubdiv -maxPolyCount 100000 -name "SUBD" "polySurface52146"`;
print(">> Poly to SUBD done!\r");
string $nurbs_geo[] = `subdToNurbs  -constructionHistory off -name "NURBS" $subdiv_geo[0]`;
print(">> Subd to NURBS done!\r");

What can I do to troubleshoot?

does it work interactively?

No, with the same commands via UI it also crashes…
The problem was not solved, but if you skip smoothing it is working. So we just did not smooth.

Poly to Subdiv is probably sensitive to topology issues that are fine for a polymesh but not reproducible in subd. You might have luck using Maya’s polygon cleanup before the conversion

1 Like