Maya viewport shading glitching

Whenever I manipulate the rig (mostly) the viewport shading looks nice with good shadows. But then when I undo or move another ctrl or randomly it looks like the normals pop back to what the model has in T pose :frowning: But I turned on the normals visibility and they are behaving correctly. So it seems to be the viewport and how it handles deformation? Is there a way I can avoid it doing that?


Notice the shadow in the crease from lipcorner to nose. It keeps disappearing and looking super flat!

I tried deleting my blendshape node for correctives, but it still does it. It’s something animators have reported as annoying, the only thing I can tell them to do as a workaround is to turn on the highres, smoothed mesh by hitting “3”. But that slows performance. Not ideal.

I’m using maya 2022 by the way. But I had the same problem in 2017 too

Afaik, by default skinCluster in maya recalculates normals every time you move something, could be related to that? Check skinCluster settings and change it to not alter normals. Sorry, dont remember attr name off the top of my head.

That didn’t fix it unfortunately. I turned OFF “Deform User Normals”. The behavious looks the same and same glitches.
I do want it to deform the normals right? If it didn’t I can only imagine weird results.

Is it possible you are dealing with “locked normals” for this mesh in particular? It may be worth setting normals to face, then smoothing them/adding hard edges where needed, and test again. Looks like the artist that made the nose set hard edges.

P.S not a rigger.

1 Like

that did it. nice

shame though I was hoping to get that data through fine with fbx. Any idea how I could preserve those hard edges with an fbx export without running into this issue?

To my understanding, Maya updates the normals of the mesh during any point that the vertices are changed. So if you ever lock the normals, you would run into this issue. I can not think of a way around it. The only option in my opinion would be to save out the edge indices to a file and then set them to hard when you load in the fbx file. But I don’t have a lot of experience with FBX files particularly so perhaps someone has a much more elegant and built-in solution.
Good luck!

1 Like