Render.exe does not start when calling subprocess from py script

Hi Everybody,
this is my very firs post here. I read a lot here, and really often found some good advice here on the site :slight_smile:

I’d like to create a small script that render/create a contactsheet of my models.
For now, my script calls mayapy.exe (via subprocess.Popen([…]), which references the model and some kind of “studio” into a new scene.
It also creates a .bat file (Bassically with "Render -r sw “path/to/render_file” as content), I will use it to manually render the new maya-file…
So, executing this *.bat file from within the explorer (by double-click), works fine.

But, I would like this .bat file being executed from within the py-script.

When calling the *.bat-file via subprocess, the render does not start (…but the cmd-window pops up for just a short moment).
I tried calling it via os.system(), but also without any success…
I tried starting the renderjob directly with “subprocess.Popen([render_exe, file_to_render])”, but also without any success…

I am using maya-software-renderer (not Arnold), so it shouldn’t be a problem with my license, right?

Do you have any advice for me, how to start a “renderjob.bat” via py-script?
thank you!:slightly_smiling_face: