Maya: skinCluster error when mirroring mesh

/ Error: file: D:/Autodesk/Maya2019/scripts/others/doMirrorSkinWeightsArgList.mel line 84: saco is not in a skinCluster.

That’s the error I get when attempting to mirror my mesh (yeah, not the joints). I try with another one and the error doesn’t come up so I guess is something related to that bind-skinned mesh and not the general settings. Good to mention that it’s not the first time I mirror this mesh but I’ve done some little changes here and there in my rig file (and closed it and opened several times) so I don’t know what’s pasando.

Any help would be highly appreciated,

I would guess you might have some extra history on the geometry. Can you show a screenshot of the input history? Or try (carefully) cleaning your mesh with delete non-deformer history.

Thanks for the tip. I’m affraid didn’ work though. I hope this snapshots help to diagnose. Before taking them, I tried the deletion of non-deformer history but I don’t notice any change. To be honest, it’s the first time I use that option (I don’t have much experience rigging things)

Thanks again!

I also notice you have 2 shapes under your transform. sacoShape and outputCloth1.

Was the polyExtrudeEdge1 still there after you delete non-deformer history? Or did it give an error when you tried it?

When I did a quick test by selecting the transform, delete non-deformer history fails with the error:
// Error: file: /Applications/Autodesk/maya2018/ line 55: More than one cachable shape is visible under pSphere1. Select the specific shape that you want to cache. //

So you would need to select the shape instead to clean the history. (That is assuming the history is causing the issue. It might not be. But it will slow down your rig.)

The command might also be finding the wrong geometry. I’ve noticed certain commands fail when you have extra history or if you have duplicate shapeOrig shapes as well. (I’m not sure how it happens, but occasionally, you can end up with an accidental extra shapeOrig node that is doing nothing.)

You could try using Python so you can directly specify the correct skinCluster.

import maya.cmds as cmds