[Maya] Disable initial calculation when opening a file?


I have a maya file where upon opening it crashes and outputs an error
Cycle Error Delta Mush Geometry Unexpected Loop or something like that.

I’m stuck on this perpetual loop, and the file is good as corrupt since I can’t open it.

Just wondering if there is a way to disable initial calculation so I can just delete the delta mush node after succesfully opening it?

P.S. The file is in mb so I can’t open it in a text editor.

Open up a new scene. Go to Modify > Evaluate Nodes. You can either do ignore all if you know what you need to fix, or turn them off one by one if you need help figuring out what is breaking it. Hopefully that gets you where you need to be so you can start digging in to fix it.

If you are having trouble identifying the issue, my suggestion is first save a copy of the file. Then start deleting chunks of the scene and save and reopen until you don’t get the error. It might take a few tries and restarts of that, but it should help to narrow down to the trouble area.

1 Like


Thanks for pointing out Modify > Evaluate Nodes
but it seems like that feature is on per file basis not on the maya itself.
In this case, even if I turned it out, and open the file, I still get the error.

I tried looking the same setting in the preferences but its not present in any category. Correct me if I’m wrong.

What if you disable evaluation and then import the file instead?

1 Like

Thanks for the response @EdArt
Unfortunately, it still does the same result (i.e. error)

Anyhow, I gave up on this and just work on the version previous to this one.

Thanks again!

I usually tend to do the following steps in the situations:

  • If a file with references, then open file option box and set to open with all references unloaded. That usually tends to fix a lot of issues when it’s anything happening with referenced nodes in the scene. After opening of scene you can then try to load the references one by one to see which one ends up erroring. (And often suddenly all load fine. Then just save as new version and check if that scene opens fine. You never know.)
  • Open file option box, disable execute script nodes. That way settings from the scene are ignored completely as it doesn’t try to run the initialization script nodes. (This should also fix the opening file trying to re-enable evaluation if it did so.)
  • Disable the Evaluate Nodes as described.
  • Pause all viewports. (E.g. the pause button at the top of maya)
  • If all that fails I tend to open in mayapy to see if that also fails under those conditions - often than magically it behaves differently.

Also, in some rare cases it could be worth trying to import your scene instead of opening it - as was already mentioned. This for example also shouldn’t mess with the evaluate modes. However, after trying the above steps I mentioned before this usually doesnt solve more things - unless its related to render settings or some odd default node setting in the scene.

And of course, if it’s a .ma file and you have a vague idea what is causing the crash you can edit the file in notepad and remove whatever is breaking things. However this might be more involved than most (non-tech) people feel confident with.

1 Like


Apologies for the late response. Things got hectic last week.
Unfortunately, I gave up on the file since I had to deliver and just used the previous version and did some rework.

Interestingly, I made the same deltamush with the same name on succedding files and it didn’t error out. Maybe it was just when I was saving that particular mb file.

Anyhow, thanks for all the suggestions. Will keep them in mind if it happens again.