Weird delay when using tablet with Maya


so I’m trying to use a drawing tablet with Maya and I’m getting some delays on the movements I try to make (be it alt+drag or everything that needs some kind of clicking). It’s like small movements are not being considered by Maya, only large swipes. Pen pressure works fine, though. Other applications work just fine. Disabling Windows Ink makes everything work as intended, but deactivates pen pressure (so not a solution). Also, the ALT, SHIFT, and CTRL bubbles/tooltip are showing up near the cursor whenever I press it, which is kind of annoying, other apps like Krita, Blender doesn’t show this at all.

I’m using a brand new Gaomon M10K Pro with the latest drivers ( and Maya 2020.4.

See this example gif pls

The ALT tooltip is next to my mouse cursor, even though I’m trying to click and drag, Maya only responds when I do a larger movement, which is irritating for weight painting, for example.


  1. Disabling Windows Ink
  2. Disabling flicks on Pen and Tablet settings (both in the control panel and registry)
  3. This

I just wanted for it to work like other apps, without this delay, does anyone know what is happening?


I’ve never used Gaomon, so this is a complete shot in the dark. But after you disable Windows ink and any other settings, maybe you need to restart either Windows or your tablet driver? It might reinitialize the pressure sensitivity. (total shot in the dark.)

1 Like

Just tested, pressure sensitivity is going nuts in Maya only (actually it’s working as a mouse, so every pen click is 100% intensity no matter what), but other software still working as intended without Windows Ink. :frowning:

Have you tried to change Viewport 2.0 rendering engine?

i’ve got some troubles with “DX11” and switching to “OpenGL-Core Profile (Compatibility)” helped.

Hey, just tried, no success too but thanks for the suggestion!
It’s weird that Maya is behaving like a normal Windows app for me instead of recognizing the input of the tablet normally as other software does. I don’t know exactly how to explain, but the weird delay looks like the pressure sensitivity is being detected and applied on the go instead of being activated all the time for Maya. It’s most noticeable when doing small strokes (skinning, for example, painting a single vertex is impossible since I need to do a large swipe before the pressure sensitivity starts to work).

Actually, that’s not the first time it happened to me, I had a Wacom and XP-Pen before that behave exactly like that, with Maya only, that’s why I gave up on trying tablets with Maya, other software is working fine with my tablets. Guess I’ll have to get used to it, my Maya is cursed. :sweat_smile:

If you are using a Windows System, make sure that Windows Ink is disabled. (Both in your Pen or Tablet driver UI, and in your PC Settings.) Windows Ink will watch for tap-Gestures which creates a delay in incompatible software. These gestures can also make a “splash” or “Halo” effect around the cursor when tapping or clicking with the pen or tablet. It is recommended that Windows Ink be disabled for Maya Users.

In the drawing tablet driver Windows Ink can be enabled, disabled for specific applications if needed.

So if you do run into problems later, you can exactly target the setting to fix the specific issue you might be having with an application.

In addition, wacom tablet has better compatibility and less issues than other brand, this article can help you a lot: 10 Best Drawing Tablets for 3D Modeling, Sculpting and Texture Painting - pctechtest