Troubleshooting FBX import


#1

I’m trying to import an fbx and I’m at the point where it seems like I can rule out the asset and the application. I’ve tried the asset on a different system and I’ve tried similar assets from the same Unity package and those combinations all work. What else can i test to troubleshoot what might be causing this?

[update] looking into it a little more and found that linking the FBX using (generic FBX) returns an error “FBX is empty.” There’s also over 1000frames and it has me wondering if there are data caps?


#2

What software have you tried opening the fbx in?
When in doubt, try motion builder as fbx is the native format for that software.


#3

Thanks for your reply. On my work laptop I cannot open the one in question with Motion Builder (it doesn’t kick back an error, it just leaves an empty scene). I’ve tried importing it both with Maya and Max and also tried using “Link FBX” in Max. The last attempt stated “file is empty.” Other FBX files from this same unity package are able to load.

On my personal laptop, I was able to import it with Maya LT, re-export it and view that with a Win10 FBX viewer. However neither of those FBX copies were able to open on my work system, which is kind of why I’m scratching my head. It’s almost like it’s a specific file, in a specific environment. Independently, both things work fine.

On both systems, the FBX loads in Unity without issue


#4

What version is the FBX in question? And what versions are your software packages?

At some point in the last few years, they changed the FBX format and broke compatibility with older versions of software packages (this happened to me)


#5

I’m using Unity2018, Autodesk Creative Suite 2015 on my work laptop, and MayaLT 2018 on my personal laptop.

Another update to add… I tried using Unity2018’s FBXExport Utility and I can output a separate FBX and this one imports but with a broken BindPose so none of the animations are there. It’s a known issue for that Utility and it also doesn’t support export to 2015 Autodesk.