Message "Multi" not showing up in Attribute Editor [Maya]


#1

Howdy folks,

I’m experimenting with and trying to wrap my mind around the workflow for hooking up a metanode network for my auto-rigger. Currently stalling on something pretty simple, but I’d love a resolution nonetheless. When I create a message multi-attribute to hold the info for a joint chain, it doesn’t show up in the Attribute Editor. I realize I can just have a single attribute for each joint in the chain, but I prefer to have a compact data representation, especially if the scene has dozens of these network meta nodes passing info around.

Thanks for any help in advance. Cheers!


#2

Without seeing the code, not sure what would be causing the attrs to not show up.

This works for me.

import pymel.core as pm
node = pm.createNode('transform')
pm.addAttr(node, shortName='jointChain', longName='jointChain', numberOfChildren=3, attributeType='compound')
pm.addAttr(node, shortName='RootJoint', longName='RootJoint', parent='jointChain', attributeType='message')
pm.addAttr(node, shortName='MidJoint', longName='MidJoint', parent='jointChain', attributeType='message')
pm.addAttr(node, shortName='EndJoint', longName='EndJoint', parent='jointChain', attributeType='message')

#3

I tested Sean’s code and it shows up for me too. What version of Maya are you in? Maybe there is a bug.

I tried connecting them in case it has the same bug as in the Node Editor (connected attrs don’t show up in nodes in at least Maya 2017.) Are there any ways to hide/filter attrs by type in the attribute editor?


#5

Thank you, snolan. My problem was setting the main attribute as a message with type “multi”, and in the case of your code snippet, using a normal compound attribute does the trick.

Cheers