Cluster error animating

rigging
maya

#1

Hello everyone!

First of all, sorry for my bad english and this is my first post with an error that I can’t resolve by myself.

I have created 2 different clusters for my lips, one for my UpperLip and the other one for my LowerLip. These clusters are being moving by 2 different follicles which are being moving by the skinCluster of the head.

Well,these clusters work perfectly in my scene but when an animator use this character and he puts keys in “head_control”, for example, the mesh of the head moves 30 units in translate Y or something similar. but in my scene this don’t happen. Do you know what is happening here?

I think it can be relationed with an operation I did in previous versions of the rig. I did Optimize -> Scene File because I wanted to solve an error of data lose cause missing nodes but I clicked every option under this command and that deleted a lot of things… But I created a new cluster and still happen the same…

Hope you can help me, thanks!!


#2

What version of Maya? (in case it is a known bug)

What is different between you and the animator? Are they referencing the rig, and you are importing it?

Weird stuff like this is sometimes related to the graphics card too.

Is it happening to all your animators? Is the animator keying everything in the hierarchy? Or just selected objects? Check their Set Key settings.

That is all I can think of without seeing more info.


#3

Hello clesage, thanks for your time

We are working with Maya 2018

We are testing the rig in his self scene, we are not referencing the rig or importing, just manual-keying controls for test.

The thing is that is happening to the rest of animators (at least in one previous rig with the same problem, the thing is that now I really need these clusters and I can’t replace them like I did before to solve the same problem). The animator is keying an only one control, which is parent of that controls deforming the lip, that’s enought to see the problem. In this previous rig I mentioned before, the problem was only on viewport and He tried to make a render and the mesh didn’t move itself weirdly.

This is a bit frustrating because I can’t test the rig where is failing… And this is a remote project so…

Animator and me did a videocall and he shared his screen and I could appreciate that the problem was the clusters and if I delete them, the problem dissapear but I really need them.

Can’t pass you a pic or something…


#4

If it is only happening on viewport, then I think it is more likely that the graphics card might be the problem.

What happens if the animator changes Evaluation Mode to DG vs. Parallel? Sometimes switching to DG fixes weird evaluation glitches, but might make the rig a lot slower.

Or, what happens if they turn GPU Override off and then on again? Does it make any difference?


#5

When he told me the problem the first thing I thought was this (Evaluation Mode or GPU Override), but I saw his animation preferences and they was the same as me mine and he didn’t have any problem with other rigs… so the problem might be in the scene.

Indeed, I rigged more characters with the same method (refering to clusters) and there was no problem.

The similar aspect between these 2 rigs which made problems was the operation I did under File -> Optimize Scene File (by default), that made too much lighter the scene (around 30 mb). But if the problem is relationed with this operation it shouldn’t fail again when I create a new Cluster, I don’t know


#6

Oh I misunderstood. I thought you said you tried it again and it still happened.

Yeah, running optimize scene file is pretty dangerous on a rig. Sometimes it removes group nodes you needed.

Do you have a backup you can return to? :frowning:


#7

Dont worry clesage, probably I didn’t explain my thoughts very good.

Well, I have previous versions of the rig before I did Optimize Scene File but these versions don’t have a lot of improvements I did recently :frowning:

But, despite of deleting conexions running Optimize Scene file… why is still happening the problem if I delete the old Clusters and I create new clusters… Maybe the problem isn’t the Optimiza Scene file…


#8

Hello everyone Who os looking for a solución.

I could resolve this problem. First if of allí it was a bug of Maya as we thought since the beginning.

What I did (my friend Javi, really, credits for him - thanks Javi-) was create an empty blendshape as front of chain in The problemátic mesh, forcing Maya to refresh in every moment.