Am I exporting the FBX wrong?

animation
rigging

#1

Hello, I am new here, and I am also new to rigging, modeling and animating in Maya.

I have found a strange problem with my animation where I try to export it as an FBX file.
After I modeled, rigged and animated, I tried using it on Unity and found it didn’t work. Unity is not the problem, of course.
So I created a new scene on Maya and inserted my FBX fine and that’s when I got the following results:

The first picture is when the character moves as he should, just as it should.

The seccond is the model after I insert the FBX on the new scene:

  • The joints are not skinned to the geometry.
  • The only thing moving are the NURB controllers (like if the bones were not constrained to them), and for some reason, the joint I made to move the gun moves as well.
  • The joints keep the pose that is reached on the middle of the animation The animation is 24 frames long, so the pose it keeps is the one on frame 12.
  • I noticed on the hierarchy, that the constraints are gone. They are nowhere to be found on the outliner.

Is it possible to tell what is going on?

Thanks for the attention, everyone.


#2

Can you share what options you’re selecting when doing the fbx export?
You’ve probably just missed a checkbox.


#3

Hey, thanks for answearing, I will post it, but it’s not the problem, because I managed to figure it out.

What was happening was that I baked the NURB controllers on the animation, but not the bones.
After I baked all the bones, the animation worked and the geometry was skinned to the joints, just as intended.

I don’t know why that solves the “mesh won’t be skinned to the bones” problem.
The constraints are still gone after I export it, even though I have the export “constraints” option on.

That was a very simple solution, but I have been strugling with it for a week now.

Thanks a lot for the attention, R.White.


#4

Nice, glad you figured it out.